Вы здесь

Какая версия joomla более распространена?

8 сообщений / 0 новое
Последняя публикация
foxseobd63
Какая версия joomla более распространена?

На какую версию joomla существует больше всего модулей, на какую версию joomla существует больше всего русскоязычной документации?

Kar
Аватар пользователя Kar

Думаю, что более всего модулей имеет Joomla 2.5. Исходя из моего опыта это наиболее стабильная версия, хотя для конкретных случаев нужна доработка, кое-что надо убрать и добавить в CSS и PHP. Но если у вас более ранняя версия, то переход лучше делать сам, вероятность ошибок велика.

serz102
Аватар пользователя serz102

Ветка 1.0.х претерпевает лишь косметические изменения, в основном улучшающие безопасность. Так что с наличием новых версий у Joomla «полный порядок». Безопасность тоже на уровне, версию 1.0.13 можно смело считать очень-очень стабильной и безопасной.

Что же касается безопасности сторонних расширений, то тут все не так гладко, что вообще-то повторяет ситуацию в целом в языке PHP, как популярном среди новичков и людей не знающих ничего о том, как ломаются сайты. 90% софта глючны, а платные программисты готовы работать за еду. Действительно сильных расширений мало, но они есть, например OpenSEF или MosetsTREE.

nem4ikov90

В 3.х версии много полезных плюшек, в сравнении с 2.5, но в своем инэт-магазине использую 2.5 и особых трудностей не возникает. Просто прежде чем выбрать версию, чтоит почитать про их принципиальные отличия, и если вы в своем проекте не планируете их использовать, то и не стоит брать более сложную систему. Давно известо, чем проще, тем надежней. Зачем вам ненужные плюшки и фенечки, которые только могут увеличить кол-во ошибок? wink

tornado5
Аватар пользователя tornado5

Версия к которой написано больше всего модулей и посвящено статей - это версия 2.5. В то же время версия 3.0 тоже обзавелась не малым количеством модулей и плагинов, но пока уступает по этому показателю версии 2.5. В тоже время в целом версия 3.0 более продвинута и проста в управлении, так что обогнать версию 2.5 по плагинам и модулям - это только дело времени. а вот версия 1.5, я считаю. уже морально устарела.

dollyleony32
Аватар пользователя dollyleony32

Да, 2.5 и 3 - самые распространеные версии, точнее документация, расшифровки что и как делать, устанавливать, менять. Также плагинов много на эти версии. Ранние версии лучше не использовать. С ними одни заморочки, тормозится все. Даже если выбирать из двух версий, то лучше 2.5.

xasan1144
Аватар пользователя xasan1144

Про 1.5 забудь, а вот 2.5 или 3 - решает каждый сам исходя из опыта и наличия необходимых расширений

Lee Van Cleef
Аватар пользователя  Lee Van Cleef

Обе версии, что 2.5x, что 3.x накопили достаточно документации, под них написано достаточное кол-во плагинов, расширений, шаблонов. Единственно 3.x несколько более продвинутая, а 2.5x считается более стабильной. Но новые проекты все же следует начинать на 3.x.

Реклама